Hylkää alkuperäinen koodi Android Studion kohdalla

Yevhen Vasilenko 09/16/2017. 2 answers, 13.729 views
android android debugging android-studio android-studio android-ndk android-ndk

Google I / O 2015 lupasi virheellisen koodin suorittamisen Android-studiossa. Tätä varten sinun täytyy asentaa ndk-bundle SDK-hallinnan avulla ja päivittää Android Studio uusimpaan versioon (Kanarian haara). Ja mitä seuraavaksi? Miten setup? Tässä on linkki lähteeseen. Lähde

2 Comments
durbnpoisn 06/08/2015
Päivityksen päivittämisen laajentaminen koko kehitystyöhön on hieman liian paljon, jotta voimme vastata tähän.
Yevhen Vasilenko 06/08/2015
Joten sanoit, että on parempi poistaa nykyinen Android Studio ja SDK ja asentaa uusi?

2 Answers


ph0b 12/18/2015.

Oikeastaan ​​mainostettu NDK-tuki ei ole vielä käytettävissä, vaikka lataatkin ndk-bundle-päivityksen ja päivität Android Studioin kanariankanavan uusimmalle versiolle (1.3-preview3 nyt).

SDK-työkalut-ryhmä totesi, että NDK-tuki ei kuulunut Android Studio 1.3: n ensimmäisiin esikatseluihin . Sen pitäisi kuitenkin olla pian - he mainitsivat hiljattain kesäkuun puolivälissä tavoitteeksi.

update : virheenkorjaustuki on nyt pois. Näin ei ollut alkuperäisen kysymyksen aikaan - kiitos kaikista siitä alhaisemmista asioista :) katsokaa donturnerin vastausta alla.

2 comments
3 Glenn Maynard 01/14/2016
Alimitanssit ovat vain vero kysymyksiin, jotka muuttuvat ajan myötä ...

donturner 06/15/2016.

Update June 2016 : Android Studio 2.1: ssä oletusasetus tukee natiivia virheenkorjausta, joten alla ei tarvitse tehdä, ellei vanhempaa versiota käytetä.

For older versions : Näin koodataksesi alkuperäisen koodin Android Studio:

  • Siirry Suorita-> Muokkaa kokoonpanoja
  • Napsauta + -merkkiä
  • Valitse asetukseksi tyyppi "Android Native"
  • Valitse avattavasta Moduulista sovelluksen moduuli
  • Lisää breakpoints C / C ++ -koodisi
  • Run> Debug ...

Sovellus tulee ottaa käyttöön ja lldb debuggeri liitetään noin 10 lldb kuluttua.

Note : Kun luot debug-määrityksen Native Debugger -osiossa, voit valita gdb , mutta tämä on vähemmän tuettua kuin lldb ja tiedetään olevan buginen. Käytä omalla vastuullasi.

5 comments
1 Alex Cohn 10/15/2015
Uskon, että gdb on lopetettu AS v.1.4: n jälkeen.
Mitch 05/01/2016
"Moduulin pudotusvalikosta valitse sovelluksesi moduuli" on Yleinen-välilehdessä v2.1 Android-studiossa
Mitch 05/01/2016
Puuttuvat ohjeet kokoonpanon nimeämisestä. Myös nämä ohjeet aiheuttavat virheen "Rakennetyyppi ei ole JNI-virheenkorjaus". Oletan, että nämä ohjeet eivät ole enää oikeita käyttöliittymän muutosten vuoksi. En vieläkään pysty suorittamaan virheenkorjausta.
4 m0skit0 06/01/2016
Ei vaihtoehtoa kuin Android Native.
2 donturner 06/15/2016
Android Native -ohjelman kokoonpanoa ei enää tueta, koska Android-sovelluksen kokoonpano tukee täysin alkuperäistä virheenkorjausta.

Related questions

Hot questions

Language

Popular Tags